Page tree
Skip to end of metadata
Go to start of metadata

 


System Overview

The Link CloudBackup service includes a hardware backup appliance (HBA) that is installed at the customer site. All customer servers and workstations are backed up to the on-site backup appliance. The appliance then replicates the backup jobs off-site to a virtual backup appliance (VBA) on the Link vCloud Platform.


Deployment Models

The HBA is initially installed at the customer site and after full backups of all servers have been performed, Link will temporarily remove the HBA to seed the VBA over a 1Gbps connection. Once the VBA is seeded the HBA is returned to the customer site. Any further replication between the HBA and VBA does not require as much network bandwidth as only changes in data are transferred to the VBA. There are two options customers can choose from to facilitate replication between the HBA and VBA. 

Internet Delivery

Customers can use their existing internet connection to perform replication between the HBA and VBA. Replication can be scheduled not to run during business hours so as not to interfere with regular internet traffic.

Private Network Delivery

Customers may choose to deploy a private network to perform replication between the HBA and VBA. This approach provides enhanced security for the network traffic as well as a much higher level of performance.


Initial Configuration

Although the hardware backup appliance is pre-configured by LinkBermuda, there are some configurations that the customer will need to setup in order to get the appliance ready for their environment. The following document describes the minimum settings that the customer should consider when preparing the appliance for use. Customers should use the supplied credentials to access the web interface of the appliance.


Dashboard

The first screen you will see after logging in is the Dashboard. The Dashboard provides a summary of the activity on the appliance. You can customize the Dashboard by adding widgets from the column on the right to the main display area. Some of the widgets inlcude: Job Statistics, Protected Data, RAID Space Usage, Client Usage and Network Throughput. 

At the bottom left of every screen you will see a bar representing the amount of diskspace used and available on the appliance. At the bottom center of every screen you will see notifications and alerts. At the bottom right of every screen you will see a status indicator for the RAID array.

The first option in the Help menu at the top right of every screen will provide detailed instructions of actions you can perform on the current screen. This is the definitive guide on how to use the features of this appliance.

On screens that display tables you have the option to download what is displayed to a file in CSV (Comma-separated variable) format. To do this click the Actions button in the top left corner and select Download CSV from the menu.

 


System

To begin configuring the appliance for your customer environment click on the System tab.

Active Directory

For ease of deployment you can enable the Active Directory settings. Click on Active Directory under the Networking heading in the menu on the left.

In the Search For field, type the name of your domain controller and then click the Find button. If the appliance finds the domain the information will populate in the Domain Information section. If this information is correct then click the Join button. When prompted, type your Domain Administrator username and password, and then click OK. Once you are connected to the Active Directory, you will have access to view the entire list of computers in your domain under the Clients > Active Directory tab.

DNS

Next click on DNS under the Networking heading in the menu on the left to add search domains and DNS servers to the appliance. This is useful if you have internal DNS servers or internal domains (e.g. Active Directory domains) on your network.

Email

Click on Email under the Monitoring heading in the menu on the left to configure the settings to allow the appliance to send out email notifications. Enter the From Address you wish to use and enter one or more email recipients (separated by commas) in the Send Email To field. You can leave the Email Server field as the default localhost which will allow the appliance to send out the email or enter the name of your own mail server. If your mail server requires a username and password enter it in the appropriate fields (leave empty if using localhost).

Host Name

Click on Host Name under the Networking heading in the menu on the left to assign a hostname and domain to the appliance.

Notifications

Click on System Alerts under the Monitoring heading in the menu on the left to enable notifications to be sent to the email address you setup in the previous steps. Check the boxes next to the reports or alerts that you wish to be notified of.

You should enable all of the System Alerts so that you will be proactively notified of any hardware issues. If you receive an alert for any hardware issue please contact LinkBermuda as soon as possible.

Password

Click on Password under the Basic heading in the menu on the left to change the admin password for logging into the web interface of the appliance.

Update

Click on the Update widget to check to see if you are running the latest version of the backup software on the appliance. Updates are set to automatically download to the appliance. When an update is available click the Install button to install it. Once the update is installed the appliance must be rebooted.

If an update is available when logging into the web interface a Notices widget will be displayed on the Dashboard and a View Notices button will appear at the bottom of the screen. You can also receive an email when an update is available by checking the New Update checkbox in Notifications.

Please remember that you should also keep your secondary replication appliance (VBA) up-to-date as well. Whenever you update the HBA, update the VBA soon after. Failing to keep both appliances on the same version can result in replication breaking.

 


Clients

The Clients tab is the section where you configure the appliance to communicate with the servers you wish to backup. 

Schedules

First click on the Schedules tab. Create one or more schedules to be applied to the backup clients. You can modify the existing default schedules or click the New button to create a new schedule.

Active Directory

If you have setup Active Directory in the previous steps you can automatically create clients for multiple physical machines on the Active Directory tab. Expand the Active Directory tree and check the box next to a folder or individual objects. Click the Create Clients button at the bottom left of the screen to create backup clients for each of the selected objects.

VMware

If you have a VMware environment, you can perform client-less backups of VMs. These VM-level backups work by taking snapshots of the VM and backing up the snapshot. On the VMware tab click the Add Connection button to create a connection to preferably your vCenter Server or the specific VM Host. Enter the User name and Password and after connecting the appliance will display all VMs in its Datacenter or on the specific VM Host. You can add multiple connections if necessary.

Click on each VM that you would like to create a backup client for (hold down the Ctrl key to select multiple items), right-click and select Register from the popup menu. Click Yes to create backup clients for each of the selected VMs.

Edit

Backup clients created on the Active Directory or VMware tabs can be edited on the Edit tab. In addition you can create a new backup client by clicking the New button in the top left of the screen.

Key fields that should be filled out are:

Client Networking

  • Address - This is the address of the server or device to be backed up

Notifications

  • Email - Enter an email address if you would like notifications to be sent to an email address other than the one defined under System > Settings > Email (e.g. if you want to notify an individual user or department for this particular server)

Backup

  • Schedule - Select a schedule from the drop-down box
  • Priority - The default priority is 10. Higher priority clients on the same schedule will be backed up first. The lower the number, the higher the priority (e.g. the appliance has the lowest priority set to 999 for its internal backups)
  • File Set - These settings determine what files and directories are backed up. You can setup filters to exclude certain files from getting backed up. This is also the area where you can specify VSS, Exchange and SQL Server database settings for Windows servers. Consult the Help menu in the upper right corner for details on these features.

Appliance Networking

  • Interface - Leave as the default Auto or set to a specific interface on the appliance.

Job Retention

Set how long you wish to keep backups of each type of backup.

  • Fulls - The entire device is backed up
  • Differentials - Only changes since the last Full backup are backed up
  • Incrementals - Only changes since the last backup (of any type) are backed up

Offsite Job Retention

Set how long you wish to keep backups of each type of backup on the offsite replication appliance.

Offsite

  • Replicate - Enabled by default. Disable if you do not wish to replicate data for this server to the offsite replication appliance.

Click the Apply button at the bottom to save changes to the client and then the ACTIVATE CONFIGURATION button at the top right to enable the changes.

NOTE: If your backup appliance is behind a firewall and you wish to backup clients outside of that firewall then in the Appliance Networking section you will have to set Interface to NAT and place the Public IP Address of the backup appliance in the NAT Address field.

There are some differences for VM backup clients on the Edit tab. The Client Networking and Appliance Networking sections are grayed out. The File Set option in the Backup section is also grayed out.

Under the Job Retention sections the Differentials and Incrementals settings are grayed out. All VM-level backups are Full backups since the backups take a snapshot of the entire VM. If the schedule dictates an Incremental or Differential backup a Synthetic Full backup will be performed if the Change Block Tracking (CBT) setting is enabled. The Synthetic Full only backs up changed data in the snapshot.

The VMware section allows you to enable the following settings:

  • Allow Change Block Tracking - Allows Incremental or Differential backups of VM backup clients (Synthetic Fulls)
  • Ignore Unallocated Sectors - When CBT is enabled only the used portion of the virtual disk is backed up
  • Quiesce Data - When the snapshot of a running VM is taken VM Tools will quiesce the file system to keep it in a consistent state

Client Install

All backup clients other than VM backup clients require client software to be installed on the server. After creating the backup client in the web interface, install the software client on the server to be backed up. Software for the various operating systems are listed under the Software tab. The easiest way to download the software directly onto the server is to get onto the server to be backed up, open a web browser to the backup appliance web interface and go to the Clients > Software tab. Alternatively you can download the software and transfer the install file to the server.

Even if a server is a VM, you can still install the client software on it. You may wish to do this for a Windows VM if it requires a SQL Server or Exchange Database to be backed up or if you have issues performing a VM-level backup of the server.

Windows Server

  1. After downloading the install file, double-click the file and follow the wizard to complete the software installation.
  2. Start the Configure Infrascale Backup program and select the radio button "Manually Assign Appliance Information". 
  3. Enter the IP address or host name of the backup appliance. Copy the Bacula Agent Password from the backup appliance web-interface on the Clients > Edit tab. Select the backup client you are configuring and copy the Password listed in the General section.
  4. Click the Verify Connectivity button. If successful you should receive a "Connection Successfully Verified" response.
  5. Click the OK button to save the settings.
  6. On the backup appliance web interface under Clients > Summary you should see a green check mark in the Status column of the client you just configured.

SQL Server

If SQL Server is installed on the server the installation wizard will detect it and ask if you wish to install the plugin. Select Yes and complete the wizard. There will be an additional tab in the Configure Infrascale Backup program where you can select which specific databases to backup.

In the backup appliance web interface go to the Clients > Edit tab and select the backup client you are configuring. Edit the File Set settings in the Backup section. In the Backup Plug-in Control section enable SQL Server.

Exchange Database

If Exchange is installed on the server the installation wizard will detect it and ask if you wish to install the plugin. Select Yes and complete the wizard. There will be an additional tab in the Configure Infrascale Backup program where you can provide additional options for the Exchange Database backup such as truncating logs after incremental and differential backups.

In the backup appliance web interface go to the Clients > Edit tab and select the backup client you are configuring. Edit the File Set settings in the Backup section. In the Backup Plug-in Control section enable Exchange Database.

Exchange Mailbox

If Exchange is installed on the server the installation wizard will detect it and ask if you wish to install the plugin. Select Yes and complete the wizard. There will be an additional tab in the Configure Infrascale Backup program where you can select the Exchange Message Store and Server to backup. You can also specify how far back to backup messages from the dropdown box at the bottom. 

If you have many mailboxes and a large number of messages in those mailboxes, performing an Exchange Mailbox backup of messages Within 6 months or greater may take days to complete. Please bear this in mind when scheduling.

In the backup appliance web interface go to the Clients > Edit tab and select the backup client you are configuring. Edit the File Set settings in the Backup section. In the Backup Plug-in Control section enable Exchange Mailbox.

 

In order to perform an Exchange Database backup and Exchange Mailbox backup on the same Exchange server you will have to install two instances of the client software. To do this install the Windows 32-bit software for one function and the Windows 64-bit software for the other function.

Non-Windows Server

The following steps are specifically for Linux, Solaris and FreeBSD. The procedure for HP/UX, MacOS and Netware are similar but you should consult the Infrascale User Guide page 112 for details.

  1. Download the client software (.tar.gz file) to a folder on the Linux server.
  2. On the backup appliance web interface go to the Clients > Summary tab and right-click the backup client you are configuring and click Download Config. Place this file (bacula-fd.conf) in the same folder as the client software file in the previous step.
  3. Extract the contents of the client software file (e.g. tar xzvf filename.tar.gz), change to the extracted folder and run the install.sh script.
  4. The installation should automatically detect the presence of the bacula-fd.conf file and copy it to the /opt/eversync/etc folder.
  5. Start the service by running the command: /etc/init.d/eversync-backup start

    Due to the presence of the bacula password displayed in plain text in the bacula-fd.conf file, the file permissions should be changed to only allow root to read the file (e.g. chmod 400 /opt/eversync/etc/bacula-fd.conf).

  6. On the backup appliance web interface under Clients > Summary you should see a green check mark in the Status column of the client you just configured.


Server

The Server tab displays the past (Recent Jobs), present (Active Jobs) and future (Scheduled Jobs) activity on the backup appliance in addition to some other jobs and the Report settings.

Reports

On the Reports tab set the time of day you want the Daily Reports email to be sent out and the day and time you want the Weekly Reports email to be sent out. This tab will display a plain text preview of the upcoming email report. The actual email reports are sent in HTML format.

Active Jobs

The Active Jobs tab displays the currently running backup jobs on the appliance.

The jobs for physical machines or with the software client installed will display the Status as Running. You can see further details by right-clicking on the job and selecting Show Client Properties.

VM backup clients do not display any useful information on this tab (just "Running PreScript"). To see the progress of active VM backup jobs go to the Clients > VMware tab, locate the VM being backed up and view the progress in the Action and Progress columns.


Jobs

The Jobs tab is the area where the actual backed up data from the backup jobs is represented. 

History

The History tab displays the outcome of the backup (or restore) jobs. The Status column displays whether the job was successful, failed, was successful but with warnings/errors or is pending replication. The Level column displays the type of backup - Full, Differential, Incremental or Synthetic Full. You can also see the actual start time of the job and its duration. 

These backup jobs listed represent the actual data backed up. If you delete a backup job from the list, you will remove the data from that backup job and also free up disk space on the appliance.

 

Retention

On the Retention tab set the default retention settings to apply when creating new backup clients.


Restores

You can perform restores from a few different locations:

  • Clients > Summary
  • Clients > VMware
  • Jobs > History

Right-click on a backup client and select either Restore to restore all files backed up in the backup job or Browse and Restore to restore one or more files in the backup job. For physical servers or devices with the backup software installed, you will see the below screen allowing you to select which backup jobs to explore.

The next window allows you to select which backup client to restore to (if you wish to restore to a different server) and which folder to place the files (if you don't want to use the original folder location). The browser window allows you to select which files and folders to restore. 

For VMware backup clients you will be presented with a different wizard for Browse and Restore as the appliance will mount the backed up VM disks. The first screen allows you to select which backup job to restore from.

Next you will be asked what type of files to restore:

  • Contained Files (Default) - files on the VM's hard disks
  • Component Files - VMware-specific files which define the VM (e.g. the vmdk file)
  • Application Data - restore applications like SQL Server or Exchange Database (requires the backup software to be installed on the VM and a backup client defined on the appliance)

Next select whether to maintain the folder path.

Review your options and click Finish to begin browsing the files.

The next window allows you to select which backup client to restore to (if you wish to restore to a different VM) and which folder to place the files (if you don't want to use the original folder location). The browser window allows you to select which files and folders to restore. 

To Browse Client... and to perform the restore, you will be prompted to log into the VM with an administrator-level account.

For VMs the Relocate to this path field is mandatory. If you selected the option Restore Full Path on the previous step and wish to restore files to their original location then only select the drive letter the files are on when you Browse Client or just type the drive letter in the Relocate to this path field. (e.g. for Windows this would be C:\ or D:\ or whatever drive the files were originally on)

 

You cannot restore individual files using Browse and Restore for Linux VM-level backups. In order to restore individual files, you will need to restore the entire Linux VM by creating as a new virtual machine. Once the new VM has been created you can copy individual files from that VM to the original VM.

To perform a Restore of a VMware backup client you will be asked whether to replace the existing VM or create a new VM.

If you choose to replace the existing VM then you will be asked if you wish to create a snapshot first and whether to power it on and connect it to the network following the restore. If you choose to create a new VM then you will be directed to specify details on which VMware Host, datastore and disk layout to use and whether to power it on and connect it to the network following the restore.


Boot (Disaster Recovery)

The Boot tab is a new feature introduced in version 6.7. It enables Disaster Recovery capability by allowing you to boot a limited amount of physical or virtual machines directly on the backup appliance. The maximum number of machines you can boot will depend on the model appliance you are using.

Appliance ModelMax. # of Machines
Infrascale vDPA (virtual)1
Infrascale 12002
Infrascale 15002
Infrascale 27004
Infrascale 45008

The maximum number of machines you can boot is the recommended number of machines that you can run on the appliance without adversely affecting the regular operation of the appliance. You can override this limit by going to the System tab and clicking on Local Boot under the Tools menu on the left. Increase the Maximum Number of VMs and click Apply. Doing so may result in degraded performance of the appliance.

In the event of a disaster you can boot two or more of your key servers either on your onsite appliance or on your offsite appliance and maintain functionality of critical services.

Exceptions

The Boot feature will not work with the following configurations:

  • VM or DR Image configured to use EFI BIOS
  • VM or DR Image with more than 4 VMDKs / Disks
  • Windows Server 2003 and Windows XP

Virtual Machines

If you have created a backup job for a virtual machine (VM) then it will automatically be listed on the Boot > Overview tab. To boot the VM, right-click on the VM and select Boot from the menu.

The Boot Status will tell you how many machines you currently have booted and your current boot limit. Click Next.

Select a backup image to restore from. Click Next.

Set the amount of CPU and RAM required for the VM as well as a Network interface on the appliance to use. Click Finish to Boot the VM on the appliance.

You can immediately access the booted machine using a VNC Client (e.g. RealVNC, UltraVNC) and connecting to the backup appliance on the VNC port number specified in the last step above.

e.g. Enter the following in the VNC Server field of your VNC Client - mybackupappliance.mydomain.bm:5901

Use this remote access to enable the network connectivity on your booted machine as outlined below.

Physical Machines

In order to boot physical machines (PMs) on the appliance you must first have a Disaster Recovery (DR) Image of the machine (an image backup). From the Clients > Software tab, download and install the Infrascale DR Imaging software on the PM.

The Infrascale DR Imaging software is only compatible with Windows servers (Windows 7 and higher and Windows Server 2008 and higher). As a result you can only boot Windows physical machines on the backup appliance.

You can only boot a PM from a DR Image backup. In the appliance web interface go to Clients > Edit and select the PM with the DR Imaging software installed. In the Disaster Recovery Image section, set a schedule for the DR Image backup to take place.

You can also perform a Manual Backup and select the checkbox Backup as DR Image to immediately create a DR Image of the PM. You can perform a Full or Incremental DR Image backup of a PM.

Once you have at least one Full DR Image of the PM you can boot from that image and the PM will be listed on the Boot > Overview tab. To boot the PM, right-click on the PM and select Boot from the menu.

The Boot Status will tell you how many machines you currently have booted and your current boot limit. Click Next.

Select a DR image to restore from. Click Next.

Set the amount of CPU and RAM required for the PM as well as a Network interface on the appliance to use. Click Finish to Boot the PM on the appliance.

You can immediately access the booted machine using a VNC Client (e.g. RealVNC, UltraVNC) and connecting to the backup appliance on the VNC port number specified in the last step above.

e.g. Enter the following in the VNC Server field of your VNC Client - mybackupappliance.mydomain.bm:5902

Use this remote access to enable the network connectivity on your booted machine as outlined below.

Network Connectivity

Once the machine is booted you will want to restore network access to the machine. If you booted to the onsite appliance then your appliance is most likely on the same network as the original PM or VM. You should ensure that the main network card on the appliance that is plugged into your local network is bridged to the booted machine. Do this by going to System > Settings > Devices and enabling the Export Virtual checkbox for that interface.

If you are booting a machine on the offsite appliance then contact LinkBermuda for instructions on network configurations for your booted machines. In this scenario the internal and/or external IP addressing may be different from the original PM or VM.

Windows

Access your booted Windows machine using a VNC Client as outlined above. Access the Network Connections and edit the new Ethernet adapter that will be present. Change the network settings to match the original Windows machine. You may see a warning that an Ethernet adapter already has these settings (referring to the original network adapter that is no longer visible). Ignore this warning and save the settings. You should now have network connectivity. 

Linux

Access your booted Linux machine using a VNC Client as outlined above. Perform the following commands to configure the new network interface:

Perform an ifconfig to see the name of the new interface and its MAC Address.

# ifconfig -a
ens3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::c60:f5ff:febf:e611 prefixlen 64 scopeid 0x20<link>
ether 0e:60:f5:bf:e6:11 txqueuelen 1000 (Ethernet)
RX packets 637123 bytes 77122966 (73.5 MiB)
RX errors 0 dropped 705 overruns 0 frame 0
TX packets 565723 bytes 110226868 (105.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Create a new UUID for the interface.

# uuidgen ens3
4fdec8f6-ca76-46d7-99fd-aadbed7b289c 

Navigate to the /etc/sysconfig/network-scripts directory and copy the old interface configuration script as a template for the new interface.

# cd /etc/sysconfig/network-scripts
# ls
ifcfg-ens5
# cp ifcfg-ens5 ifcfg-ens3 

Edit the new interface configuration script and enter new values for the device, name, UUID and MAC Address.

ifcfg-ens3

DEVICE=ens3
TYPE=Ethernet
BOOTPROTO=static
DEFROUTE=yes
NAME=ens3
UUID=4fdec8f6-ca76-46d7-99fd-aadbed7b289c
ONBOOT=yes
HWADDR=0E:60:F5:BF:E6:11
IPADDR=172.16.120.25
PREFIX0=24
GATEWAY=172.16.120.1
DNS1=8.8.8.8
DNS2=8.8.4.4
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

Reset the new interface.

# ifdown ens3
# ifup ens3 

You should now have network connectivity.

Rollback

Once the original PM or VM is back in service, you can take the following steps to bring the original back up-to-date with any changes that have occurred while the booted machine was running.

  1. Power off the booted machine on the appliance.
  2. On the Boot > Active tab right-click on the powered off machine and select Create Backup Job.
  3. A backup job of the current state of the booted machine will be created and seen under Jobs > History.
  4. Right-click on this job and select Restore to restore any changes back to the original machine (see the Restores section above).

 


References

Infrascale User Guide

  • No labels